07-20-2022 Curtailment - Calvert City, KY
Incident Report for River Financial
Resolved
This incident has been resolved.
Posted Jul 21, 2022 - 02:05 UTC
Monitoring
Four hour power curtailment starting at 3pm EST
Posted Jul 20, 2022 - 19:30 UTC
This incident affected: Mining (Calvert City, KY).