Degraded Service

Incident Report for River Financial

Resolved

Full service has been restored. We have confirmed that all systems are functioning normally following the resolution of the upstream Google Cloud issue. Thank you for your patience and understanding during this incident.
Posted Jun 12, 2025 - 22:32 UTC

Monitoring

There is currently an incident impacting sign ups and non-essential document downloads. This is due to a Google Cloud outage upstream. We are actively monitoring the issue.
Posted Jun 12, 2025 - 19:14 UTC
This incident affected: Website.