Onchain withdrawals delayed
Incident Report for River Financial
Resolved
This incident has been resolved.
Posted Sep 30, 2024 - 20:15 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 30, 2024 - 15:33 UTC
This incident affected: Bitcoin (On-chain transactions).