On-chain withdrawals under maintenance
Incident Report for River Financial
Resolved
This incident has been resolved.
Posted Oct 27, 2021 - 02:20 UTC
Update
We are continuing to investigate this issue.
Posted Oct 27, 2021 - 02:20 UTC
Investigating
Bitcoin withdrawals are currently under maintenance
Posted Oct 26, 2021 - 23:02 UTC
This incident affected: Bitcoin (On-chain transactions).