07-12-2022 Curtailment - Marble, NC
Incident Report for River Financial
Resolved
This incident has been resolved.
Posted Jul 13, 2022 - 23:00 UTC
Monitoring
Four hour power curtailment starting at 3pm EST
Posted Jul 12, 2022 - 19:19 UTC
This incident affected: Mining (Marble, NC).