On-chain withdrawal delays
Incident Report for River Financial
Resolved
This incident has been resolved.
Posted Nov 08, 2021 - 21:23 UTC
Identified
We are experiencing delays in on-chain withdrawals. Our team is working to resolve.
Posted Nov 08, 2021 - 06:50 UTC
This incident affected: Bitcoin (On-chain transactions).