07-14-2022 Transformer Maintenance - Grand Forks, ND
Incident Report for River Financial
Resolved
This incident has been resolved.
Posted Jul 20, 2022 - 19:24 UTC
Monitoring
Between July 14th and July 16th, miners will be taken down in tranches over 3-5 hour periods while the utility performs scheduled maintenance on transformers.
Posted Jul 14, 2022 - 18:51 UTC
This incident affected: Mining (Grand Forks, ND).