03-24-2023 Power Maintenance - Iraan, TX
Incident Report for River Financial
Resolved
This transformer was brought back online Friday (3/31) evening and miners have returned to hashing.
Posted Apr 03, 2023 - 18:33 UTC
Update
We are continuing to monitor for any further issues.
Posted Mar 27, 2023 - 17:17 UTC
Monitoring
A portion of the site lost power late Friday afternoon due to electrical equipment failure. Maintenance is underway and when a timeline is known this will be updated.
Posted Mar 27, 2023 - 01:51 UTC
This incident affected: Mining (Iraan, TX).