SMS Outage

Incident Report for River Financial

Resolved

This incident has been resolved.
Posted May 13, 2023 - 17:26 UTC

Identified

We are experiencing an issue with our SMS provider and are working to resolve
Posted May 13, 2023 - 05:30 UTC
This incident affected: Website.