Bitcoin transaction outage
Incident Report for River Financial
Resolved
This incident has been resolved.
Posted Feb 20, 2024 - 13:54 UTC
Update
We have resolved the issues. All new transactions will proceed normally. We are working to process the backlog of transactions initiated during the incident.
Posted Feb 17, 2024 - 20:49 UTC
Identified
We have identified an issue that is impacting Bitcoin transaction processing and are working on a fix
Posted Feb 17, 2024 - 19:50 UTC
This incident affected: Bitcoin (On-chain transactions, Lightning Network).