07-23-2022 Curtailment - Marble, NC
Incident Report for River Financial
Resolved
This incident has been resolved.
Posted Jul 24, 2022 - 01:05 UTC
Monitoring
Four hour power curtailment starting at 3pm EST.
Posted Jul 23, 2022 - 19:48 UTC
This incident affected: Mining (Marble, NC).