07-21-2022 Curtailment - Grand Forks, ND
Incident Report for River Financial
Resolved
This incident has been resolved.
Posted Jul 22, 2022 - 13:39 UTC
Identified
Four hour power curtailment starting at 6pm EST
Posted Jul 21, 2022 - 17:40 UTC
This incident affected: Mining (Grand Forks, ND).